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An error occurred while trying to access the server Print E-mail
(0 votes, average 0 out of 5)
Written by CognosLord   
Thursday, 10 June 2010 00:00
Product:
Cognos Controller 8.5

Symptom:
Error direct when you start the Cognos Controller Client, before you have selected the database to use.
The user gets this message:
An error occurred while trying to access the server.

This can be because of other things also – but look into the Windows event log to get more clues.

Windows event log shows:

Event Type:    Error
Event Source:    DCOM
Event Category:    None
Event ID:    10016
Date:        2010-06-01
Time:        14:09:57
User:        NT AUTHORITY\NETWORK SERVICE
Computer:    SERVER
Description:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{114133CF-5DC0-4DB1-8796-4642553B2499}
 to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20).  This security permission can be modified using the Component Services administrative tool.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Event Type:    Warning
Event Source:    Cognos Controller
Event Category:    None
Event ID:    0
Date:        2010-06-01
Time:        14:09:57
User:        N/A
Computer:    SERVER
Description:
Error occured at 2010-06-01 14:09:57 in IBM Cognos 8 Controller, Error No=5, Source=FrangoDirect.ConnectionDirect.SetSelectDb#ControllerProxyClient, Description=System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.UnauthorizedAccessException: Retrieving the COM class factory for component with CLSID {114133CF-5DC0-4DB1-8796-4642553B2499} failed due to the following error: 80070005.
   at Cognos.Controller.Proxy.CCRWS.ConnectionBusiness_SetSelectDb(String sGuid, String sUser, Boolean bSelectDb)
   --- End of inner exception stack trace ---, HelpFile= HelpContext=0
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Cause:
The user account does not have rights in the Cognos Controller COM parts to perform.

Solution:
You can inside Cognos Controller Configuration on the COM+ server dialog do this;

Uncheck the settings for “Enforce Access checks for the Controller COM+ application”.

OR

Add the group Everyone to the list of users that is allowed to run Cognos Controller in the same Cognos Controller Configuration dialog. It is in the “Controller COM+ roles and users” section.

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