Home Knowledge Articles IBM Cognos 8 BI Initializing process Cognos Metric Store fails: 'ocijdbc9 does not exist' error
Follow us on Twitter


Countries

50.1%United States United States
7.6%India India
7%United Kingdom United Kingdom
5.1%Australia Australia
4.8%Canada Canada

Visitors

Today: 34
Yesterday: 111
Last Week: 3357
This Month: 9186
Last Month: 16191
Total: 382839


Initializing process Cognos Metric Store fails: 'ocijdbc9 does not exist' error Print E-mail
(0 votes, average 0 out of 5)
Wednesday, 21 April 2010 08:31

Symptom
During the process of initializing a new metric store in Oracle 10G, the error"ocijdbc9 file does not exist" appears.
   
Cause     
Metrics Studio is using the JDBC driver to connect to the Metrics database. The same driver is used for the BI content store. The BI content store is not so sensitive, as the Metrics software concerning this driver version. Therefore the correct Oracle 10G version of classes12.jar must be used.

Solution
1. Check if the Correct Oracle 10G client is installed on the Cognos server, i.e. Oracle Client has the exact same version as the Oracle database server.
2. Stop Cognos service, because the classes12.jar is used to read and write to the BI content store as well
3. Copy the classes12.jar file from the ORACLE_HOME\jdbc\lib directory to the Cognos c8_location\p2pd\WEB-INF\lib directory.
4. Start Cognos service again
5. Initialize the Metric store

www.cogknowhow.com

Comments

Please login to post comments or replies.
 
 

Login

For more content en features!



CogKnowHow Newsletter

Season's Greetings


Receive HTML?

Polls

How many users are working on your Cognos environment?